All Collections
Dashboard
Settings
Which MetaTrader version do I need to install?
Which MetaTrader version do I need to install?
Updated over a week ago

The MetaTrader 4 version is the "classic" version of the MetaTrader trading platforms. It is still used by many people and many (external) indicators or trading robots (EAs) are available for MT4.

MetaTrader 5 is the newest version, where you get access to many more trading instruments and always get the latest technical updates & developments of the platform.

Put simply: if you are looking for a special indicator or EA which may only exist for MT4, feel free to choose MT4. If you are looking for the newest, most modern version, take a look at MT5.

Did this answer your question?